Linux下Mplayer播放器的安装

  安装完Fedora,我就想装个听歌软件,毕竟工作之余,听听歌是个很不错的放松方式.

  这篇教程记录了我的Mplayer安装之路,同时包括了各个阶段可能碰到的问题都有解答.谈不上什么独创,只希望能给像我一样的菜菜们一些帮助.

  该mplayer所需软件我全部都安装了,为什么却还提示缺少libtheora.so.0(libtheora.so.1.0)它呢,难道libtheora.so.0(libtheora.so.1.0)与libtheora.so.0两个不一样嘛.

  libtheora.so.0(libtheora.so.1.0) is needed by
mplayer-1.0pre8-1.i386

   [root@Superren backup]# !534
   rpm -q –whatprovides libtheora.so.0
   libtheora-1.0alpha4-2
   [root@Superren backup]# !535
   rpm -q –whatrequires libtheora.so.0
   gstreamer-plugins-0.8.8-6
   [root@Superren backup]# rpm -q libtheora
   libtheora-1.0alpha4-2
   [root@Superren backup]# rpm -q gstreamer
   gstreamer-0.8.10-1
   [root@Superren backup]#

  意思是mplayer需要这个libtheora.so.0东东.调用相关命令检测

  第一步:下载相关安装源文件.
  目前Mplayer的官方站点http://www.mplayerhq.hu提供的了MPlayer v1.0pre8
的下载,我的Fedora是FC4版的.在下了该Mplayer最新版本后,并不能顺利安装.有如下错误信息:

  第一步:下载相关安装源文件.
  目前Mplayer的官方站点http://www.mplayerhq.hu提供的了MPlayer v1.0pre8
的下载,我的Fedora是FC版的.在下了该Mplayer最新版本后,并不能顺利安装.有如下错误信息:

  验证一下,果真不一样,libtheora.so.0(libtheora.so.1.0)对应的是ibtheora-1.0alpha5-1.2.1,是与FC5匹配的,libtheora.so.0对应的是libtheora-1.0alpha4-2.我的Fedora是4.0的,保险起见,我决定不装ibtheora-1.0alpha5-1.2.1,改为换Mplayer的版本.于是从
http://www1.mplayerhq.hu/MPlayer/releases/MPlayer-1.0pre7.tar.bz2该地址载了个Opre7的.同时从官网下了最新的codecs:essential-20060611.tar.bz2以及皮肤Blue-1.6.tar.bz2和字体font-arial-iso-8859-1.tar.bz2.[![](https://www.linuxidc.com/linuxfile/logo.gif)](http://www.linuxidc.com)

  网上一堆Linux牛们写的各种Linux下的听歌软件安装教程,在这里我代表我们这些菜菜们对这些牛们致以最崇高的敬意.但是由于我们这些菜菜真的是很菜,按照牛们写的教程安装下来总是碰到这样那样的问题,但是牛们的教程里根本没写是如何解决这些问题的,俺们菜菜们就慌了,这咋办呢,只好到处发贴求人,最后一般差不多都解决不了.因为牛们没碰到过啊.

  意思是mplayer需要这个libtheora.so.0东东.调用相关命令检测

  安装完Fedora,我就想装个听歌软件,毕竟工作之余,听听歌是个很不错的放松方式.

  网上一堆Linux牛们写的各种Linux下的听歌软件安装教程,在这里我代表我们这些菜菜们对这些牛们致以最崇高的敬意.但是由于我们这些菜菜真的是很菜,按照牛们写的教程安装下来总是碰到这样那样的问题,但是牛们的教程里根本没写是如何解决这些问题的,俺们菜菜们就慌了,这咋办呢,只好到处发贴求人,最后一般差不多都解决不了.因为牛们没碰到过啊.

  [root@Superren backup]# !534
  rpm -q –whatprovides libtheora.so.0
  libtheora-1.0alpha4-2
  [root@Superren backup]# !535
  rpm -q –whatrequires libtheora.so.0
  gstreamer-plugins-0.8.8-6
  [root@Superren backup]# rpm -q libtheora
  libtheora-1.0alpha4-2
  [root@Superren backup]# rpm -q gstreamer
  gstreamer-0.8.10-1
  [root@Superren
backup]#图片 1

  这篇教程记录了我的Mplayer安装之路,同时包括了各个阶段可能碰到的问题都有解答.谈不上什么独创,只希望能给像我一样的菜菜们一些帮助.

   libtheora.i386 1.0alpha5-1.2.1 core
   Matched from:
   libtheora.so.0(libtheora.so.1.0)

   yum provides ‘libtheora.so.0(libtheora.so.1.0)’
   Loading “installonlyn” plugin
   Searching Packages:
   Setting up repositories
   livna [1/5]
   updates [2/5]
   core [3/5]
   extras [4/5]
   panorama [5/5]
   Reading repository metadata in from local files

  libtheora.so.0(libtheora.so.1.0) is needed by
mplayer-1.0pre8-1.i386